Tag: android gradle

Umschalten auf Gradle: Warum muss ich die kundenspezifischen Ansichten von der Verschleierung behalten?

Ich bewege ein Projekt von Ameise nach Gradle, aber da ist etwas, das ich einfach nicht herausfinden kann. FAKTEN Nach dem Aufbau einer Freigabe APK (dh verschleiert), bemerkte ich, dass die App war schlecht abgestürzt . Der Fehler kann hierauf zusammengefasst werden: java.lang.NoSuchMethodException: <init> [class android.content.Context, interface android.util.AttributeSet] Ein Debug (dh nicht verschleierter) APK funktioniert […]

Android Studio kann das Repository nicht beheben

In meinem Projekt versuche ich, die Design-Support-Bibliothek zu benutzen. Ich habe in meiner Gradle-Datei: dependencies { …. compile 'com.android.support:design' …. } Und wenn ich versuche, das zu bauen, bekomme ich den Fehler: Normalerweise würde ich einfach auf Install Repository and sync project klicken, aber das scheint nicht mehr zu arbeiten . Klicken Sie auf das […]

'Java' Plugin ist nicht kompatibel mit den Android Plugins

Ich bekomme einen Fehler, nachdem ich Android Studio installiert und eine einfache App erstellt habe. Schritte folgten: Frisch Download & installierte Android Studio. Ein neues Projekt erstellt. Wenn das Projekt geladen wurde, scheiterte der Gradle mit Fehler: Error:The 'java' plugin has been applied, but it is not compatible with the Android plugins. Modul Gradle Datei: […]

Paketname der Anwendungsvariante im gradle plugin erhalten

Ich baue ein gradle Plugin, das für jede Anwendungsvariante eine neue Aufgabe hinzufügt. Diese neue Aufgabe benötigt den Paketnamen der Anwendungsvariante. Dies ist mein aktueller Code, der mit der aktuellsten Version des Android-Plugins nicht mehr funktioniert: private String getPackageName(ApplicationVariant variant) { // TODO: There's probably a better way to get the package name of the […]

App deklariert eine Abhängigkeit von der Konfiguration 'compile' zur Konfiguration 'default', die nicht im Deskriptor für Projekt deklariert ist

Ich importiere ein Bibliotheksmodul namens "Verschleiß" in meinem Projekt und beim Bauen bekomme ich das: Fehler: Es ist ein Problem beim Konfigurieren des Projekts ': app' aufgetreten. Konnte nicht alle Abhängigkeiten für die Konfiguration ': app: _debugApk' lösen. Projekt: app deklariert eine Abhängigkeit von der Konfiguration 'compile' zur Konfiguration 'default', die nicht im Deskriptor für […]

Gradle: Konnte kein Plugin vom Typ AppPlugin erstellen

Ich kann nicht scheinen, um meine Android-App mit Gradle zu bauen. Build.gradle: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } dependencies { compile 'com.intellij:annotations:12.0' } android { compileSdkVersion 19 buildToolsVersion "19" defaultConfig { minSdkVersion 14 targetSdkVersion 19 versionCode = 82 versionName = "0.6.1" } […]

Wie deaktiviere ich lint abortOnError in Android Gradle Plugin von der obersten Ebene der Multi-Projekt-Verzeichnis

Ich habe ein Top-Level-Android-Gradle-Projekt. Es gibt mehrere Teilprojekte, die unterhalb dieser Projekte verschachtelt sind (manchmal sind sie 2 Level tief) dh: top level project | project1 vendor libraries | lib1 lib2 Lint bricht meinen Bau in einigen der Bibliotheksprojekte ab. Ich kann jedes einzelne Bibliotheksprojekt build.gradle , um das Problem zu beheben android { lintOptions […]

Setup Gradle, um Java ausführbare Datei in Android Studio auszuführen

Also hier ist der Deal: Ich bin mit ORMLite für Android, die Annotationen für seine Mapping in Android verwendet. Wie Sie wissen, sind Annotationen in Android langsam, und die Macher von ORMLite haben dies erkannt, so dass sie die Möglichkeit, eine Java-Datei ausführen, um eine Ressource-Datei, die die Notwendigkeit, um Annotationen zur Laufzeit in der […]

Amazon Device Messaging Stub! Android Studio

Ich versuche, Amazon Device Messaging mit Android Studio zu integrieren. Zuerst folgte ich ( Integration-your-app-with-adm ). Wenn ich anrufe ADM adm = new ADM(getActivity()); if (adm.isSupported()) { // … } Es gibt diese Ausgabe auf Logcat: E / AndroidRuntime (24472): java.lang.RuntimeException: Stub! E / AndroidRuntime (24472): bei com.amazon.device.messaging.ADM (Unbekannte Quelle) So folgte ich Amazons ( […]

Android Studio 3.0 canary – Fehler behoben: org.apache.httpcomponents: httpclient: 4.0.1

Ich habe AS 3.0 Canary installiert, ein bestehendes Projekt importiert und beim Ausführen von gradle sync bekam ich diesen Fehler: Failed to resolve: org.apache.httpcomponents:httpclient:4.0.1 Ich habe versucht, das Projekt zu reinigen, und das scheiterte auch. Das war ein Teil des Fehlers: Required by: project :app > com.google.api-client:google-api-client-android:1.22.0 > com.google.http-client:google-http-client-android:1.22.0 > com.google.http-client:google-http-client:1.22.0 Ich schaute auf andere […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.