Tag: eklipse

Android Eclipse – Kann keine Annotationsverarbeitungsoption sehen

Ich bin nicht in der Lage, die Option zu setzen, um die Annotationsverarbeitung in meinen Eclipse-Einstellungen festzulegen. Nicht sicher, seit wann bekomme ich dieses Problem aber sicherlich hat es begonnen, auftreten, nachdem ich Eclipse zuletzt aktualisiert habe. Ich habe auch versucht, einfügen die Annotations.jar Datei in Tools / Support-Ordner, aber nicht gut. Freundlich helfen. TIA

Android-Abhängigkeiten verweist auf nicht vorhandene Bibliothek google-play-services_lib.jar

Ich habe eine schreckliche Zeit versucht, eine einfache Karte zu erhalten, um in einer App zu erscheinen, wie in der Google Maps v2 Dokumentation gezeigt. Eclipse sagt immer wieder: Der Container 'Android Dependencies' verweist auf nicht vorhandene Bibliotheken 'X: \ Android Development \ workspace \ google-play-services_lib \ bin \ google-play-services_lib.jar' Ich fand ein paar Leute […]

Anwendung gibt keine API-Ebene an

Ich fange gerade an, Eclipse für Android-Anwendungen zu verwenden. Ich habe installiert Eclipse 3.5.2 und Java 5 AVD ist Android 2.1 API 7 Mein anfängliches Hallo Android Programm lief gut, wird aber nicht wieder laufen. Den folgenden Fehler erhalten: [2010-07-25 09:47:31 – HalloAndroid] WARNUNG: Anwendung gibt keine API-Level-Anforderung! [2010-07-25 09:47:31 – HalloAndroid] Geräte-API-Version ist 7 […]

Beim Erstellen eines Projekts in einem neuen Arbeitsbereich ist ein Fehler aufgetreten

Bin neu für die Android-Entwicklung. Ich habe versucht, einen neuen Arbeitsbereich mit Target SDK als API 21 zu erstellen und mit API 19 kompiliert zu haben . Ich habe die Sdk von API19 und 20 und nicht die Android5 installiert . Ich habe einen neuen Arbeitsbereich erstellt und ein neues Projekt erstellt, in dem ich […]

Beim Sammeln von zu installierenden Gegenständen ist ein Fehler aufgetreten

Als ich versuchte, mein Android SDK zu aktualisieren, bekam ich die folgenden Fehler. Was soll ich machen? An error occurred while collecting items to be installed session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,com.android.ide.eclipse.adt,22.0.5.v201307292155–757759 No repository found containing: osgi.bundle,com.android.ide.eclipse.adt.package,22.0.5.v201307292155–757759 No repository found containing: osgi.bundle,com.android.ide.eclipse.base,22.0.5.v201307292155–757759 No repository found containing: osgi.bundle,com.android.ide.eclipse.ddms,22.0.5.v201307292155–757759 No repository found […]

Verwenden von Android-Bibliothek in Eclipse und Springen zu Klassendateien anstelle von Quelldatei, die innerhalb von Eclipse-Arbeitsbereich ist

Ich fand diesen Bug http://code.google.com/p/android/issues/detail?id=20731 das ist gelöst, aber es hat nicht genau dieses Problem, aber ich sehe in Kommentare, dass dies dort als Problem erwähnt wird. Gibt es einen Weg in Eclipse, um Abhängigkeiten im Projekt irgendwie einzurichten, dass ich in der Lage sein werde, normalerweise an die Quelle zu springen, wenn ich im […]

ADT Eclipse + Gradle: unvollständig BuildConfig.java

Ich benutze die Android Developer Tools 22, Eclipse Indigo und das aktuelle Gradle Plugin für Eclipse. Jetzt möchte ich verschiedene Aromen verwenden, indem ich in der Datei build.gradle definiere: productFlavors{ A { packageName "com.test.A" buildConfig "public final static String FLAVOR = \"A\";" } B { packageName "com.test.B" buildConfig "public final static String FLAVOR = \"B\";" […]

Android-Logcat-Fehler: ZipFileCache: init fehlgeschlagen, wenn offene Zip-Datei – gerätespezifisch?

Haben Sie Schwierigkeiten, irgendwelche nützlichen Protokolle von LogCat zu erhalten. Meine App funktioniert gut (beide Geräte), und alle Protokolle sind auch gut mit meinem Nexus Gerät. Aber mit meinem Handy (Huawei P8 Lite, nicht verwurzelt, Android 5) Ich bekomme diese Fehlermeldung: 11-12 11: 21: 07.740: E / ZipFileCache (7584): init fehlgeschlagen beim Öffnen der Zip-Datei. […]

Wo kann man google-services.json Datei in Eclipse-Projekt?

Ich versuche, den neuen GCM client auf Android zu implementieren. An einem Punkt müssen Sie Google Services für die App aktivieren. Nachdem Sie Cloud Messaging aktiviert haben, müssen Sie die Datei google-services.json herunterladen und in das app/ oder mobile/ Directory einfügen. Das Problem ist, dass in meinem Eclipse-Projekt diese Verzeichnisse nicht existieren. Also meine Frage […]

Verwenden Sie neue Firebase-Sdk im Android-Eclipse-Projekt

Neue Firebase mit großartigen Features wurde gerade angekündigt, aber laut Dokumentation ( https://firebase.google.com/docs/android/setup#prerequisites ) ist android studio (sowie gradle) jetzt erforderlich. Für jetzt in meinen cocos2d-x apps muss ich ADT / Eclipse verwenden, um apps zu bauen, da gradle noch nicht unterstützt wird (aber cocos2d-x team arbeitet daran). Ich bin jetzt mit einer älteren Version […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.