Tag: eklipse

"Message description not found" Warnungen in strings.xml

Ich bekomme Tonnen von lästigen Warnungen aus meinen Strings.xml. Links von jeder Deklaration bekomme ich eine Warnung, die "Message Beschreibung nicht gefunden" sagt. Wie kann ich es beheben?

Debugging auf Honeywell Dolphin von Eclipse

Ich entwickle eine Scanner-App für Honeywell Dolphin 7800 Geräte, kann aber nicht herausfinden, wie man Eklipse das Gerät entdeckt. Usb debugging ist aktiviert sowie Allow non-Market applications (auch Gerät zeigt USB debugging connected Benachrichtigung). Ich habe versucht Neustart Eclipse, Adb-Server und Gerät. Ich arbeite an OSX , und ich adb_usb.ini ich muss adb_usb.ini bearbeiten, wie […]

Fehler: Android-Quelle baut in Eclipse

Beim Versuch, Android-Quelle zu Eclipse hinzufügen, bekomme ich die folgenden Fehler. Project 'android' is missing required library: 'out/target/common/obj/JAVA_LIBRARIES/gsf-client_intermediates/javalib.jar' Project 'android' is missing required library: 'out/target/common/obj/JAVA_LIBRARIES/google-common_intermediates/javalib.jar' FYI, ich habe die Quelle erfolgreich mit full_maguro-userdebug Konfiguration (für Galaxy Nexus) vor dem Hinzufügen dieses zu Eclipse gebaut. Da ich in Eclipse Indigo kein "Projekt aus vorhandener Quelle" gefunden […]

Eclipse tritt in die Klasse in Android

Ich habe ein einfaches Android-Projekt, das ich versuche, in Eclipse zu debuggen. Wenn ich es im Debug-Modus ausführe und die "Step Over" -Taste betreibe, scheint es häufig, in Android-Code zu gehen (ich will es nicht, dies zu tun, so wie ein C-Debugger nicht in libc gehen wird). Ich bekomme einen Bildschirm, der so aussieht wie: […]

Kann ich API Level X Attribute in meinem Manifest setzen, wenn mein MinSdkVersion kleiner als X ist?

Ich arbeite an einer Android-Anwendung, wo ich gerne die bigHeap und hardwareAccelerated Flags auf haben würde. Allerdings muss es auch Android 2.3 unterstützen. Meine AndroidManifest.xml sieht wie folgt aus: <uses-sdk android:minSdkVersion="10" android:targetSdkVersion="10"/> <application android:icon="@drawable/icon" android:label="@string/app_name" android:hardwareAccelerated="true" android:largeHeap="true" > Doch Eclipse weigert sich, das Projekt zu bauen und sagt: error: No resource identifier found for attribute […]

Android / Eclipse / Vorzeitiges Ende der XML-Datei

Lassen Sie mich anfangen zu erkennen, dass ich hier eine ähnliche Frage gefunden habe, aber es gab nur eine Antwort und diese Antwort trat in meiner Situation nicht auf … also … Ich bin gerade jetzt in Android waten und sind auf einen Klebepunkt gekommen. Ich benutze Eclipse und habe in ein Problem versucht, eine […]

Android-Gerät erscheint nicht online in Ubuntu 12.04

Ich habe gerade aktualisiert meine Ubuntu 11.10 bis 12.04 und bekommen dieses Problem, mein Android-Gerät nicht online erscheinen, während ich Android-Projekt aus eclipse.I've hat einen Screenshot. Ich stelle auch die Datei in /etc/udev/rules.d/51-android.rules ein. Der Inhalt der 51-android.rules-Datei ist SUBSYSTEM == "usb", SYSFS {idVendor} == "0bb4", MODE = "0666" SUBSYSTEM == "usb_device", SYSFS {idVendor} == […]

Verwenden der lokalen Json-Datei in Android

Ich werde eine lokale JSON-Datei mit einigen Daten verwenden. Meine Frage ist, wo ist die beste / richtige Art und Weise, um die Datei zu speichern und wie soll ich darauf zugreifen und es ist Inhalt? Ich habe mit json durch http vor, aber nicht eine lokale gearbeitet.

AndroidStaggeredGrid Gradle Bibliothek für Eclipse

In meinem RSS-Reader-Projekt brauche ich nettes Raster für verschiedene Größen (die Bild und Text enthalten). Ich suchte nach Lösungen, um ein Staggered Grid in Android zu machen und stieß auf AndroidStaggeredGrid Bibliothek von Etsy. Ich benutze Eclipse, aber die Bibliothek wurde für Gradle gemacht. Ich möchte diese Bibliothek in meinem Android-Projekt verwenden. Ich habe schon […]

Android Package Builder Fehler: Nicht unterstützte Major Minor Version 52.0

Ich verwende derzeit Eclipse Mars (64 Bit) unter Windows 7 64 Bit OS. Ich habe JDK 1.7 (64 Bit) installiert. Ich habe diese Eclipse seit seit einem Monat mit dem ADT Plugin von Anfang an installiert. Doch vor kurzem, als ich mein Android-SDK aktualisiert habe, um die neueste Android N-Plattform aufzunehmen, bekomme ich Fehler beim […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.