Tag: eklipse

Umbenennen von Android-Paketname fehlschlägt

Ich klicke auf mein Projekt in Eclipse, Android-Tools, 'Umbenennen Anwendungspaket'. Wählen Sie einen beliebigen Namen und es wird fehlschlagen, indem Sie auf das Fehlerprotokoll für Details. Da finde ich folgendes: eclipse.buildId=M20110210-1200 java.version=1.6.0_26 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=nl_BE Framework arguments: -product org.eclipse.epp.package.java.product Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.java.product […]

Verschieben Sie das Android-Eclipse-Projekt in den Arbeitsbereich

Eclipse macht mir das wirklich. Ich habe ein Android-Projekt, das nicht im Arbeitsbereich ist. Da Android-Projekte nicht ordnungsgemäß funktionieren, wenn Sie Eclipse's Import> vorhandenes Projekt verwenden, müssen Sie ein neues Android-Projekt aus einem Ordner auf dem Datenträger erstellen. Wenn dieser Ordner in Ihrem Arbeitsbereich ist, wird es nicht funktionieren. Wenn es nicht funktioniert, aber dann […]

FEHLER: Die Verarbeitungsanweisungszielanpassung " " ist nicht erlaubt

Ich benutze Eclipse, um eine Android-App zu programmieren, und ich bin zum Stillstand gekommen. Ich habe versucht, meinen Code zu schließen <?xml version="1.0" encoding="utf-8"?> Aber ich bekomme immer die Fehlermeldung "Die Verarbeitungsanweisungszielanpassung" [xX] [mM] [lL] "ist nicht erlaubt." Hier ist der Code: <?xml version="1.0" encoding="utf-8"?> <LinearLayout xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" android:layout_width="match_parent" android:layout_height="match_parent" android:orientation="horizontal" > <EditText android:id="@+id/editText1" android:layout_width="match_parent" […]

R-Klasse fehlt nach dem Erstellen von Android-Projekt aus vorhandener Quelle

Ich habe die Quelle für SpriteMethodTest heruntergeladen, und ich möchte es in Eclipse aufbauen. Also ging ich: Datei >> Neues >> Android-Projekt >> Projekt aus der vorhandenen Quelle erstellen >> SpriteMethodTest Es hat das Projekt erstellt, aber die R-Klasse wird nicht generiert. Jede Datei, die auf eine Ressource in R verweist, R cannot be resolved […]

Android-Liste Dateien in Assets Unterordner enthalten

Ich schaffe einige Ordner in Vermögenswerte. Jeder Ordner enthält Dateien, die ich auflisten möchte. Ich benutze folgenden Code, aber ich bekomme immer einen Nullwert für fileList. Vielen Dank. Ich verwendete, listFiles("/assets/images/","nothing"); private void listFiles(String dirFrom, String dirTo) { File f = new File(dirFrom); String fileList[] = f.list(); if (fileList != null) { for ( int […]

Android SDK veröffentlicht Ubuntu 10.04lts

Ich habe die anderen Fragen hier und in anderen Foren gesehen. Die Antworten haben mir nicht gefallen. Ich begann ursprünglich mit 11.10 aber dachte, es könnte ein Bug oder etwas, das es von der Arbeit zu stoppen. Ich habe das SDK und ADT mit Eclipse auf 10.04 und 11.10 gearbeitet, also bin ich wirklich in […]

Fehler beim Exportieren von Archivdatei oder Dateisystem mit Eclipse (Android)

Ich möchte mein Projekt exportieren, um den Code in ein neues Projekt zu verwenden. Jedes Mal, wenn ich versuche, es zu exportieren, sowohl "Dateisystem" und "Archivdatei" bekomme ich Fehler Problems were encountered during export: Error exporting name_of_my_project/bin/jarlist.cache: Resource is out of sync with the file system: '/name_of_my_project/bin/jarlist.cache'. Resource is out of sync with the file […]

Dex kann nicht ausgeführt werden: Mehrere Dex-Dateien definieren Lcom / google / android / gms / analytics / intern / Command

Ich habe mein Android SDK letzte Nacht (31.4) aktualisiert und danach habe ich meine App nicht mehr kompilieren. Ich bekomme diesen Fehler: [2015-05-01 14:36:24 – Dex Loader] Unable to execute dex: Multiple dex files define Lcom/google/android/gms/analytics/internal/Command$1; [2015-05-01 14:36:24 – SoFit] Conversion to Dalvik format failed: Unable to execute dex: Multiple dex files define Lcom/google/android/gms/analytics/internal/Command$1; Ich […]

ERROR: Anwendung erfordert API Version 14. Geräte-API-Version ist 13 (Android 3.2.1)

Ich folge einem Tutorial zum Erstellen einer einfachen Anwendung in Android und kompiliere es mit Eclipse unter Linux . Das Problem ist, dass ich beim ersten Erstellen des Projekts die Ziel- API 14 verwendet habe . Aber meine Tablette hat nur API 13 , also habe ich es in project > properties > android auf […]

Android – Aufruf erfordert API Level 9 (aktuell min ist 8): android.os.StrictMode # setThreadPolicy

Ich bin neu bei JSON. Ich folgte diesem Tutorial , um Beispiel App zu erstellen. Wenn ich versuche, den Code zu meiner Eklipse zu kopieren, zeigt er Fehler an. Call requires API level 9 (current min is 8): android.os.StrictMode#setThreadPolicy Bitte Ratschläge Vielen Dank

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.