Tag: gradle

Wie benutzt man Robolectric 2.4 in Android Studio 1.1.0 & gradle 2.2.1

Ich kann mein Android Studio Projekt nicht mit Robolectric konfigurieren. Könnte jemand mich Schritt für Schritt führen, um ein Android Studio 1.1.0 Projekt mit Robolectric 2.4 & gradle 2.2.1 zu bauen Diese Beispielprojekte funktionieren gut. Https://github.com/robolectric/deckard-gradle . Aber ich bin nicht in der Lage, es in meinem bestehenden Android Studio-Projekte zu implementieren. // unten sind […]

Gradle Javadoc Aufgabe ohne Warnungen

Ich generiere eine Javadoc .jar Datei mit Gradle für mein Android Projekt. Ich benutze ein ähnliches Setup wie in dieser Anleitung . Aber ich bekomme viele Warnungen, dass viele Symbole fehlen. Ich habe bemerkt, dass die javadoc-Aufgabe keine meiner Abhängigkeiten findet. Wie kann ich meine Abhängigkeiten zum Klassenpfad der javadoc-Aufgabe hinzufügen? Hier ist meine Upload-Aufgabe: […]

Android studio BaseGameUtils

Ich versuche, Google Play Game Services zu implementieren, und ich muss BaseGameUtils als Bibliothek in meinem Projekt haben. Nach den Google-Tutorials konnte ich keinen Weg finden, dies in ein Projekt aufzunehmen, das ich schon im Android-Studio habe. Manuelles Importieren von Android Studio … Wie soll ich BaseGameUtils in einem bereits vorhandenen Projekt importieren? Was ist […]

Ich bin nicht immer 'com.google.android.gms: Play-Services-Brieftasche: 8.4.0' Update für Google Play Services in Sdk

Ich habe mein Android-SDK komplett noch aktualisiert Ich bin nicht immer Update für Google Play-Dienste Version 8.4.0 dh 'com.google.android.gms: Play-Services-Brieftasche: 8.4.0' wie in der Link für die Implementierung von Android Pay erwähnt Https://developers.google.com/android-pay/android/tutorial . Wann immer ich diese Zeile hinzufügen: "compile" com.google.android.gms: play-services-wallet: 8.4.0 '"in build.gradle bekomme ich folgende fehler: Fehler beim Auflösen: com.google.android.gms: Play-Service-Brieftasche: […]

Mehrere Datei wurde mit dem OS-unabhängigen Pfad 'META-INF / LICENSE' gefunden

Wenn ich meine App baue, bekomme ich einen Fehler. Fehler: Ausführung fehlgeschlagen für Task ': app: transformResourcesWithMergeJavaResForDebug'. Mehrere Datei wurde mit dem OS-unabhängigen Pfad 'META-INF / LICENSE' gefunden Dies ist meine build.gradle Datei apply plugin: 'com.android.application' apply plugin: 'kotlin-android' android { compileSdkVersion 25 buildToolsVersion "25.0.2" defaultConfig { applicationId "cn.sz.cyrus.kotlintest" minSdkVersion 14 targetSdkVersion 25 versionCode 1 […]

Kotlin Gradle Ausgabe

Ich habe ein Jar eines Projektes in Kotlin-Sprache geschrieben. Jar enthält folgende Ordner: com jet kotlin meta-inf okio org Dann habe ich ein Android-Projekt erstellt und Kotlin und das Glas als Abhängigkeit hinzugefügt. Wenn ich versuche, die Hallo Welt App auszuführen, wirft es folgende Ausnahme aus. com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command '/usr/lib/jvm/java-7-openjdk-amd64/bin/java'' finished with non-zero exit […]

Gradle-Modul und Git-Submodul

Ich habe ein Bibliotheksprojekt namens Toolkit mit zwei Modulen core und database , mit dieser config: Einstellungen include ':core' include ':database' Core build.gradle dependencies { compile 'com.android.support:support-v4:20.+' compile 'com.jakewharton:butterknife:5.1.+' compile 'com.google.code.gson:gson:2.2.+' compile 'uk.co.chrisjenx:calligraphy:0.7.+' compile files('libs/flurry-3.4.0.jar') } Datenbank build.gradle dependencies { compile project(':core') } Es ist ok, wenn ich meine Tests in diesem Bibliotheksprojekt ausführen, aber […]

Android Studio – Buildvarianten werden nicht angezeigt

Ich habe vor kurzem Android Studio auf Version 0.3.0 aktualisiert und jetzt gibt es keine Build-Varianten, die ich wählen kann. Ich habe versucht, das Projekt zu reinigen und wieder aufzubauen und das Android Studio ohne Erfolg neu zu starten. Mein build.gradle ist android { compileSdkVersion 18 buildToolsVersion "18.0.1" defaultConfig { minSdkVersion 9 targetSdkVersion 18 versionCode […]

Wie kann ich Android Studio einrichten, damit ich kompilieren kann, wenn es offline ist (vom Internet getrennt)

Ich arbeite in androidstudio heute und meine Builds fingen an zu versagen. Zu meiner Überraschung hatte ich meine Internetverbindung verloren und konnte meinen Code nicht mehr bauen. Build.gradle-Datei enthält folgendes: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.3' } tasks.withType(Compile) { options.encoding = "UTF-8" } } apply plugin: 'android-library' dependencies { compile files('libs/android-support-v4.jar') […]

Migration des Projekts zum neuen experimentellen Gradle Plugin

Ich versuche, mein Android-Projekt zu einem neuen experimentellen Gradle-Plugin zu migrieren. Ich folgte den Anweisungen auf dieser Seite. Ich habe Änderungen in den erforderlichen Dateien vorgenommen, aber ich habe einen Fehler, wenn ich versuche, Synchronisierungsprojekt mit Staffel-Dateien zu machen. Fehler: Die Klasse 'com.android.build.gradle.managed.ProductFlavor_Impl' kann nicht geladen werden. Mögliche Ursachen für diesen unerwarteten Fehler sind: Der […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.