Tag: gradle

Ein Fehler beim Erstellen eines neuen Projekts im Android-Studio

Jedes Mal, wenn ich neues Projekt schaffe bekomme ich diesen Fehler: Failed to import new Gradle project: Could not fetch model of type 'IdeaProject' using Gradle distribution 'http://services.gradle.org/distributions/gradle-1.6-bin.zip'. Unable to start the daemon process. This problem might be caused by incorrect configuration of the daemon. For example, an unrecognized jvm option is used. Please refer […]

Fehler beim Auflösen: com.github.PhilJay: MPAndroidChart: v2.1.4

Ich benutze MPAndroidChart libarary in android studio.But, wenn ich versuche, gradle zu synchronisieren, die einen Fehler als unten Bild gegeben hat. Gradle Text ist hier zu kompilieren MPAndroidChart libarary. compile 'com.github.PhilJay:MPAndroidChart:v2.1.4' Bitte helfen Sie, dieses Problem zu beheben. Danke im Voraus

Android Studio gradle kompiliert die angegebene Version nicht

Ich habe dieses kleine Projekt seit einigen Tagen entwickelt, aber plötzlich hat Android Studio begonnen, mir diesen Fehler zu geben Error:Execution failed for task ':app:processDebugManifest'. > Manifest merger failed : uses-sdk:minSdkVersion 14 cannot be smaller than version 14 declared in library com.android.support:support-v4:21.0.0-rc1 Ich habe verstanden, dass es ist, weil es versucht, die Bibliothek von Android-L […]

Wie man Plugin auf nur einen Geschmack in gradle anwendet?

Ich habe ein Multi-Aroma, Multi-Build-typisierte Android-Projekt und ich möchte das NewRelic Plugin integrieren. Aber ich muss es nur für einen der Kunden anwenden, also nur für ein Produktgeschmack. NewRelic verwendet Instrumentierung und das Plugin würde Code in anderen Geschmacksrichtungen generieren, wenn ich das Plugin dort angewendet habe und das für uns nicht erlaubt ist. Also […]

Konnte die Eigenschaft 'compile' nicht finden auf org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler_Decorated@397740e0

Ich arbeitete durch einen Vortrag mit dem parse.com Starterprogramm für zwei Tage ohne Ausgabe. Ich ging weg für ein paar Minuten und ohne irgendetwas, was ich sehen kann, geändert zu werden und jetzt wird es nicht synchronisieren. Ich habe gesucht, aber nichts gefunden, was ich falsch sehen kann Vielen Dank im Voraus für Ihre Hilfe. […]

Keine Klasse gefunden "android.support.multidex.MultiDexApplication" auf Pfad: DexPathList

Ich versuche die neue MultiDex-Unterstützung auf meiner App und so weit habe ich es geschafft, meine App korrekt zu kompilieren, aber beim Laufen bekomme ich die folgende Ausnahme: java.lang.RuntimeException: Unable to instantiate application android.support.multidex.MultiDexApplication: java.lang.ClassNotFoundException: Didn't find class "android.support.multidex.MultiDexApplication" on path: DexPathList[[zip file "/data/app/me.myapp.main-2.apk"],nativeLibraryDirectories=[/data/app-lib/me..main-2, /vendor/lib, /system/lib]] at android.app.LoadedApk.makeApplication(LoadedApk.java:507) at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4382) at android.app.ActivityThread.access$1500(ActivityThread.java:139) at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1270) at […]

Android: ExternalSystemException: String-Index außerhalb der Reichweite: -130 Building Release

Also, gerade aktualisiert auf Android Studio 1.4 Beta 4 und Schwierigkeiten beim Erstellen eines Release-Builds. Ich kann ein Debug-Build gut machen. Dies ist der Fehler, den ich bekomme: ExternalSystemException: String index out of range: -130 Bei weiterer Inspektion sehe ich das: String index out of range: -130 com.intellij.openapi.externalSystem.model.ExternalSystemException: String index out of range: -130 at […]

Nach dem Update – crash com.google.android.gms: Play-Services: 5.2.8

Meine Abhängigkeiten: compile "com.android.support:appcompat-v7:20.+" compile 'com.google.android.gms:play-services:5.2.08' compile 'com.android.support:support-v4:21.0.+' Aber noch: Google Play-Dienste veraltet. Benötigt 5208000 aber gefunden 5089036 wie ist das möglich? UPDATE diese Arbeit: compile 'com.google.android.gms:play-services:5.0.89' oder compile 'com.google.android.gms:play-services:6.1.11' oder compile 'com.google.android.gms:play-services:6.+'

Java.lang.VerifyError beim Ausführen von Android-Tests mit testCoverageEnabled = true

Ich habe vor kurzem die neue Jacoco Code Abdeckung Feature für Android Gradle Plugin versucht, und leider macht es meine Tests scheitern mit dem folgenden Fehler: java.lang.VerifyError: com/foo/bar/rest/SomeClass at com.foo.bar.test.rest.BaseTest.setUp(BaseTest.java:87) at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:190) at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:175) at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:555) at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1584) Ich habe die Codeabdeckung mit diesen Zeilen in build.gradle aktiviert: buildTypes { debug { testCoverageEnabled = true […]

Gradle konnte die Bibliothek in Android Studio nicht auflösen

Ich möchte eine Bibliothek in Android Studio, aber es zeigt Fehler wie unten: "Fehler behoben: com.lemonlab: expandable-button-menu: 1.0.0" Wie kann ich dieses Problem beheben? apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion '21.1.2' defaultConfig { applicationId "ayowes.com.newecampus" minSdkVersion 15 targetSdkVersion 21 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android-ptimize.txt'), 'proguard-rules.txt' […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.