Fehler beim Auflösen: com.android.support:cardview-v7:26.0.0 android

Ich versuche, recyclerview zu meinem Projekt hinzuzufügen und diesen Fehler zu erscheinen und ich habe es von Android-Studio-Abhängigkeiten hinzugefügt Dies ist ein Fehler beim Versuch, recyclerview in android studio hinzuzufügen

Das ist die kompilierte Version ...

  • ACCESS_COARSE_LOCATION-Berechtigung gibt eine Zellenturm-Präzision auf Android
  • QML virtuelle Tastatur Dimensionen
  • Sind Android BroadcastReceivers in einem neuen Thread gestartet?
  • Android bekommt Fragment Breite
  • Zeitplan in android verlegen
  • Tastatur ausblenden beim Anzeigen von DialogFragment auf Tablet?
  • Alternative zu zxing QR Leser Bibliothek für Java / Android?
  • Android In App Bestellstatus Aufladbar
  • SSL Client auf Android
  • Drehen einer Kamera SurfaceView zum Portrait
  • PhoneGap Kamera startet die Anwendung neu
  • Relatives Layout Zwischen 2 Artikeln
  • 10 Solutions collect form web for “Fehler beim Auflösen: com.android.support:cardview-v7:26.0.0 android”

    Ab Version 26 der Supportbibliotheken ist darauf zu achten, dass der Abschnitt " repositories " einen Maven-Abschnitt mit dem Endpunkt " https://maven.google.com " enthält.

    Etwas wie;

     allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 

    Im Fall habe ich gefunden OneSignal änderte ihre Abhängigkeiten

    So habe ich es geändert

    compile 'com.onesignal:OneSignal:[3.5.8, 3.99.99]'

    nach

    compile 'com.onesignal:OneSignal:[3.5.8, 3.5.8]'

    Dann funktioniert es, überprüfen Sie bitte alle unspezifischen Abhängigkeit.

    So habe ich es funktioniert.

    1. Add maven { url "https://maven.google.com" } als @Gabriele_Mariotti schlägt oben vor.

       allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } 
    2. Dann auf der build.gradle-Datei im App-Ordner hinzufügen

       compileSdkVersion 26 buildToolsVersion "25.0.3" defaultConfig { applicationId "com.xxx.yyy" minSdkVersion 16 targetSdkVersion 26 } 
    3. Dann auf die Abhängigkeiten verwenden

       dependencies { compile 'com.android.support:appcompat-v7:26.0.1' compile 'com.android.support:design:26.0.1' compile 'com.google.android.gms:play-services-maps:11.0.4' compile 'com.google.android.gms:play-services-location:11.0.4' compile 'com.mcxiaoke.volley:library-aar:1.0.0' compile 'com.android.support:cardview-v7:26.0.1' } 

    Fügen Sie diese auf die Projektebene build.gradle Datei und es sollte gut funktionieren.

     allprojects { repositories { google() // this is to be added if there's something already. jcenter() } } 

    Ich habe das gleiche Problem, während ich meine SDK und Android Studio Version (3.0 Beta) aktualisiert habe. Ich habe dieses Problem durch dieses Tutorial gelöst . In diesem haben sie uns zu aktualisieren bauen Konfigurationsdatei wie

     android { compileSdkVersion 26 buildToolsVersion '26.0.0' defaultConfig { targetSdkVersion 26 } ... } dependencies { compile 'com.android.support:appcompat-v7:26.0.0' } // REQUIRED: Google's new Maven repo is required for the latest // support library that is compatible with Android 8.0 repositories { maven { url 'https://maven.google.com' // Alternative URL is 'https://dl.google.com/dl/android/maven2/' } } 

    Hoffe, es wird dir helfen.

    Versuche zu kompilieren

      compile 'com.android.support:cardview-v7:25.3.1' 

    Aktualisieren Sie Ihr Android Support Repository von sdk Manager.

    Verwenden Sie compile 'com.android.support:cardview-v7:25.4.0'
    Wenn du Version 26 compile 'com.android.support:cardview-v7:26.0.0-beta2' du compile 'com.android.support:cardview-v7:26.0.0-beta2' , weil es jetzt Beta ist

    Es gibt einen anderen Weg, um Google Repository hinzuzufügen

    1. gradle-4.1-rc-1-all in gradle-wrapper.properties hinzu.

       distributionUrl=https\://services.gradle.org/distributions/gradle-4.1-rc-1-all.zip 
    2. Dann füge google() in der obersten Ebene build.gradle hinzu

       allprojects { repositories { google() jcenter() } } 

    Es hat mit mir gearbeitet, wenn ich diese Versionen von Abhängigkeiten verwende Bildbeschreibung hier eingeben

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.