Fehler beim Auflösen: com.google.firebase: firebase-core: 9.6.0

Habe alles nach FB-Dokumentation hier, aber ich bekomme immer noch folgende Fehlermeldung beim Kompilieren:

Error:(44, 13) Failed to resolve: com.google.firebase:firebase-core:9.6.0 

Mein SDK-Manager sagt, dass alles aktuell ist:

  • Android: wie man das Layout auf den Button klicken kann?
  • Java.net.SocketException: Berechtigung für android verweigert
  • GreenDAO unterstützt mehrere Beziehungen zwischen Tabellen
  • Proguard halten Klassenzimmer
  • Wie man transitive Abhängigkeiten eines anderen Teilprojekts in Multiprojekt-Builds ausschließt?
  • Version von SQLite in Android verwendet?
  •  Google Play services Rev. 33 installed Google Repository Rev. 35 installed 

    Dies ist mein build.gradle Inhalt:

     apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion '23.0.3' defaultConfig { applicationId "xxxx.xxxx" minSdkVersion 16 targetSdkVersion 23 versionCode 14 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { // Support libraries compile 'com.android.support:appcompat-v7:23.1.1' compile 'com.android.support:design:23.1.1' // Google APIs // Note: Avoid compiling the entire play-services package. compile 'com.google.android.gms:play-services-gcm:9.4.0' compile 'com.google.android.gms:play-services-location:9.4.0' compile 'com.google.android.gms:play-services-maps:9.4.0' compile 'com.google.android.gms:play-services-places:9.4.0' compile 'com.google.maps.android:android-maps-utils:0.4.4' compile 'org.jsoup:jsoup:1.9.2' compile 'com.google.code.gson:gson:2.7' compile 'io.branch.sdk.android:library:2.+' compile 'com.google.firebase:firebase-core:9.6.0' //<-- CAUSING TROUBLE } apply plugin: 'com.google.gms.google-services' 

    Dies ist meine Wurzel Ebene build.gradle Inhalt:

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.1.3' classpath 'com.google.gms:google-services:3.0.0' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

    Warum ist es nicht kompiliert?

  • Was sind die neuen Features von Android Design Support Library und wie man seine Snackbar benutzt?
  • Android NDK: Was soll ich in Application.mk für APP_ABI setzen?
  • CardView in RecyclerView hat zusätzliche Margen
  • Fragment und Elternleben Lebenszyklus zusammen
  • Android PlaceFilter Nutzung mit Google Places API
  • Android-Back-Taste und MediaController
  • 3 Solutions collect form web for “Fehler beim Auflösen: com.google.firebase: firebase-core: 9.6.0”

    Versuchen Sie compile 'com.google.firebase:firebase-messaging:9.4.0' anstatt compile 'com.google.firebase:firebase-core:9.6.0'

    Die Antwort @Lorenzo Quiroli wird Ihnen wahrscheinlich helfen, Sie benötigen die gleiche Version von Firebase und Google Play Services.

    In meinem Fall hatte ich alles auf 9.6.0 eingestellt, war aber immer noch der Fehler. Ich habe es durch die Aktualisierung der neuesten Google-Play-Services und Google Repository über den SDK Manager gelöst:

    Bildbeschreibung hier eingeben

    Jetzt weiß ich, dass das dir nicht helfen wird, weil du diese schon aktualisiert hast, aber es könnte jemand anderem helfen.

    Sie müssen die gleiche Version von Firebase und Google Play Services verwenden. Also, wenn du auf Firebase 9.6.0 SDK aktualisieren willst, solltest du auch die anderen Abhängigkeiten aktualisieren:

     compile 'com.google.android.gms:play-services-gcm:9.6.0' compile 'com.google.android.gms:play-services-location:9.6.0' compile 'com.google.android.gms:play-services-maps:9.6.0' compile 'com.google.android.gms:play-services-places:9.6.0' 
    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.