Fehler beim Auflösen: junit: junit: 4.12 in android studio 1.4 auf ubuntu

Wenn ich ein neues Projekt in android studio 1.4 auf ubuntu schaffe.

Ich bekomme diesen Fehler, wenn die Synchronisation von gradle abgeschlossen ist

  • Android-Annotationen / Gradle / Android Studio bauen Probleme
  • Warnungen Ihr Apk verwendet Berechtigungen, die eine Datenschutzrichtlinie erfordern: (android.permission.READ_PHONE_STATE)
  • Android Studio 0.5.9: 2 ärgerlich Gradle Warnungen
  • Android-Studio fügt unerwünschte Berechtigung nach dem Ausführen der Anwendung auf echten Gerät
  • Firebase-Assistent zeigt nicht in Studio 2.2.3
  • Android Studio signiert APK nicht installieren
  • testCompile 'junit:junit:4.12' 

    Mit der Nachricht auf app / build.gradle

     Error:(23, 17) Failed to resolve: junit:junit:4.12 Show in File Show in Project Structure dialog 

    // bauen gradle (app module)

     apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.example.abhishek.vearch" minSdkVersion 16 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' } 

    // bauen gradle (projekt)

    // Top-Level-Build-Datei, in der Sie Konfigurationsoptionen für alle Unterprojekte / Module hinzufügen können.

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.3.0' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } task clean(type: Delete) { delete rootProject.buildDir } 
    • Ich habe versucht Fehler: (23, 17) Fehler behoben: junit: junit: 4.12

  • Fehler beim Auflösen: com.android.support:appcompat-v7:26.0.0
  • Keystore und Aliase - gibt es einen Einsatz für mehrere Aliase?
  • Wie kann ich die drawableRight-Ressource per Code setzen?
  • Crashlytics hat einen ungültigen API-Schlüssel gefunden
  • Wie benutzt man freie Cloud-Datenbank mit Android-App?
  • Können wir mehrere Apps in einem Android Studio Projekt haben?
  • 5 Solutions collect form web for “Fehler beim Auflösen: junit: junit: 4.12 in android studio 1.4 auf ubuntu”

    Einige Leute haben durch Hinzufügen von unten Block für fehlende URL für Repository gelöst.

     android { ..... repositories { maven { url 'http://repo1.maven.org/maven2' } } ..... } 

    Um nur zu erwähnen: Klicken Sie mit der rechten Maustaste auf den 'App' Ordner und klicken Sie auf 'Module öffnen'. Gehen Sie dann zum letzten Tab 'Abhängigkeiten' und fügen Sie junit neu hinzu. Ich habe versucht, frühere Versionen hinzuzufügen, aber ich habe es nicht geschafft.

    Wenn du Open JDK 8 benutzt hast, könnte es wegen eines Bugs mit den Cacerts sein. Vielleicht könntest du folgendes versuchen, die gebrochenen cacerts zu reparieren:

     $ sudo dpkg --purge --force-depends ca-certificates-java $ sudo apt-get install ca-certificates-java 

    Ich habe versucht, meine jcenter () auf die mit der URL zu ändern und zu versuchen, es zu maven {url …} zu ändern und beide haben nicht funktioniert. Das hat es für mich behoben.

    Siehe: https://stackoverflow.com/a/33440168

    In meinem Fall war ich hinter einem Proxy und das Problem wurde mit beiden gelöst

     jcenter { url "http://jcenter.bintray.com/" } 

    und

     repositories { maven { url 'http://repo1.maven.org/maven2' } } 

    Wenn Sie sich mit junit auseinandersetzen: junit4.12 . Das ist die Lösung .

     repositories { maven { url 'http://repo1.maven.org/maven2' } jcenter { url "http://jcenter.bintray.com/" } } 

    Fügen Sie diese oben zwei Zeile nach

     apply plugin: 'com.android.application' 

    // diese Zeile entfernen – testCompile 'junit: junit: 4.12'

    Und sync wieder … arbeitete für mich –

     dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' //remove this line from here compile 'com.android.support:appcompat-v7:23.0.1' } 
    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.