Fehler beim Auflösen von com.google.firebase: firebase-core: 10.0.1

Ich möchte Firebase Cloud Messaging in meiner Android App verwenden. Dies ist meine App Level Levelle Datei

apply plugin: 'com.android.application' android { signingConfigs { config { keyAlias 'androiddebugkey' keyPassword 'android' } config1 { keyPassword 'android' } } compileSdkVersion 23 buildToolsVersion "23.0.3" packagingOptions { exclude 'main/AndroidManifest.xml' } defaultConfig { applicationId "com.shikhar.dexter.project" minSdkVersion 19 targetSdkVersion 22 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile 'com.google.firebase:firebase-messaging:10.0.1' compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.android.support:design:23.4.0' compile 'com.android.support:cardview-v7:23.4.0' compile 'com.android.support:recyclerview-v7:23.4.0' compile 'com.android.support:support-v4:23.4.0' compile 'com.google.android.gms:play-services:9.0.0' compile 'com.google.android.gms:play-services-auth:9.0.0' } apply plugin: 'com.google.gms.google-services' 

Dies ist meine root Ebene gradle Datei

  • ActionBarDrawerToggle v7 Pfeilfarbe
  • Kann das Android-Handy die Windows DirectX-Bibliothek nutzen?
  • Füge eine benutzerdefinierte Ansicht rechts neben der Symbolleiste hinzu
  • ADB drückt mehrere Dateien mit der gleichen Erweiterung mit einem einzigen Befehl
  • RequestLocationUpdates Intervall in Android
  • Geräte mit Android 4.2 (Jelly Bean) unterstützt Bluetooth Low Energy (BLE)
  •   // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.2.3' classpath 'com.google.gms:google-services:3.0.0' classpath 'com.android.tools.build:gradle:2.1.0' // NOTE: Do not place your application depndencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() maven{ url "http://dl.bintray.com/dasar/maven" } } } 

    Während der Kompilierung zeigt es diese Fehler:

     Failed to resolve: com.google.firebase:firebase-core:10.0.1 Error:(36, 13) Failed to resolve: com.google.firebase:firebase-messaging:10.0.1 

    Ich habe versucht mit verschiedenen Google Play Services Versionen wie 9.4.0 aber trotzdem funktioniert es nicht.

  • Setzen Sie die Position von TextView in RemoteView während der Laufzeit ein
  • Wie analysiere ich eine Android / data/anr/traces.txt Datei?
  • Ist es in Ordnung, wenn wir die OnDestroy () - Methode in jeder Aktivität der Android Applikation überschreiben?
  • Wie recycleview Adapter unter einem anderen recycleview Adapter?
  • Android Webview + Javascript nicht zeigen Ausgabe in Android 4.0.x, 3.x
  • Vertikale Linie mit XML ziehbar
  • 5 Solutions collect form web for “Fehler beim Auflösen von com.google.firebase: firebase-core: 10.0.1”

    Öffnen Sie den SDK Manager und stellen Sie sicher, dass Sie die neueste "Google Play Services" -Angebote heruntergeladen haben.

    Zusätzlich zum Herunterladen der neuesten "Google Play Services", wie von John Oreilly oben vorgeschlagen, musste ich auch mein 'Google Repository' aktualisieren, um es zu arbeiten.

    In Android Studio gehen Sie zu "Tools -> Android -> SDK Manager". Im SDK-Manager wählen Sie die Registerkarte "SDK Tools" und unten "Support Repository" finden Sie 'Google Repository', aktualisieren Sie es, wenn es nicht die neueste Version verwendet.

    Wahrscheinlich benötigt man ein Update von Google Play Services und Google Repository .

    Im Android Studio SDK Manager :

    • Wählen Sie die Registerkarte SDK-Werkzeuge
    • Wählen und installieren Sie Google Play Services und Google Repository
    • Synchronisieren und bauen

    Siehe Screenshot

    Versuchen Sie, alle Google-Abhängigkeiten der gleichen Version hinzuzufügen und die "Google Play Services" im SDK Manager zu speichern.

     compile 'com.google.firebase:firebase-appindexing:10.0.0' compile 'com.google.android.gms:play-services-auth:10.0.0' compile 'com.google.android.gms:play-services-places:10.0.0' 

    Hatte gerade das Problem, das mit dem Update vom Support Repository v44 bis v45 (Mitte März 2107); Der Repository-Standort plötzlich verändert und damit einige Abhängigkeiten brach, was zu der gleichen Fehlermeldung (der Grund, warum ich dies als eine mögliche Antwort hinzufügen möchte).

    In der Projektebene build.gradle befindet sich das Repository v44 unter:

     repositories { maven { url '... /sdk/extras/android/m2repository' } } 

    Während sich das Repository v45 inzwischen befindet:

     repositories { maven { url '... /sdk/extras/m2repository' } } 

    Um zu aktualisieren und Debug-Informationen zu erhalten:

     ./gradlew clean --debug 

    Auch bei anderen Versionen des Repositorys kann es helfen, die Verzeichnisstruktur zu durchsuchen und den Standort des Repositorys mit dem Ort zu vergleichen, auf den im build.gradle , der diese Abhängigkeiten hosten soll.

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.