Fehler beim Ausführen von Builder 'Android Resource Manager' auf ADT

Ich bin vor einem Problem, wenn ich versuche, neue Android-Projekt in Eclipse-Adt-Plugin-Tools zu erstellen.

FEHLER / AUSNAHME ::

  • Eclipse Android Emulator - Tastatur funktioniert nicht
  • Eclipse Indigo - Kann das Android ADT Plugin nicht installieren
  • Update Android SDK Tool auf 22.0.4 (neueste Version) ab 22.0.1
  • Android SDK erfordert Android-Toolkit Version 17.0.0 oder höher
  • Gradle ADT 0.4 Fehler: android.buildToolsVersion fehlt
  • Wie bekomme ich Fragment-Layout zu Beginn der Erstellung einer neuen App in ADT?
  • Errors occurred during the build. Errors running builder 'Android Resource Manager' on project 'test'. java.lang.NullPointerException

    Ich habe dieses Problem schon zweimal vorgestellt. Nur Lösung war, Windows-Betriebssystem neu zu installieren, das tatsächlich das Problem gelöst hat. Aber ich möchte eine echte Lösung, ohne Windows neu zu installieren.

  • Bildadapter auslaufender Speicher
  • Sind vererbte Methoden gegen die Dex-Methode in Android zu zählen?
  • Ist es möglich, das Scrollen auf einer listView zu deaktivieren?
  • ActivityNotFoundException, wenn das Paket des jeweiligen Pakets in PreferenceScreen
  • Wie man Bilddatei von Galerie zu einem anderen Ordner programmgesteuert in Android kopiert
  • Android-Entwickler-Konsolen-App-Update
  • 19 Solutions collect form web for “Fehler beim Ausführen von Builder 'Android Resource Manager' auf ADT”

    Die Umstellung auf einen neuen Arbeitsbereich arbeitete für mich.

    Datei-> Arbeitsbereich wechseln.

    Fand eine bessere lösung Im Projekt-Assistenten erstellen. Erstellen Sie keine Aktivität im Assistenten. Einfach aufheben eine Aktivität erstellen und einfach die Aktivität manuell im Manifest erstellen.

    Ich denke, Sie aktualisieren Ihr Java auf java7u55.

    Denn ich benutze Mac, aber FYI

    Ich löse dies durch bearbeiten eclipse.ini, zwingen die ide, Java zu verwenden 1.6

    -vm /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Commands/java

    Du könntest das selbe ausprobieren.

    In meinem Fall wurde der Fehler durch Ändern der Arbeitsbereichsordnerberechtigungen mit chmod 777 behoben.

    Ich verwende Mac OS X und lade das ADT Bundle für Mac herunter.

    Wenn du die Eklipse schließst und dann deine Systemprozesse betrachte und trotzdem noch Adb läuft, dann ist das das Problem – es ist abgestürzt. In meinem Fall war es, weil ich Erweiterungsdateien für andere Programme in meinem JRE habe, dass das Adb nicht zu mögen scheint. Entfernen Sie alle Ihre ext-Dateien, zwingen Sie Ihre adb.exe herunter und starten Sie dann die Eclipse neu.

    Wurzelausnahme:

     java.lang.NoClassDefFoundError: org/apache/log4j/Priority 

    Normalerweise bedeutet dies, dass sie noch einmal einen Bug eingeführt haben.

    Die "magischen Pässe", die helfen können oder nicht helfen, sind:

    1. Drücken Sie F5 (refresh)
    2. Updates Android, Eclipse und ADT (wissen, dass Sie ein solches Problem haben, ich selbst definitiv nicht tun, solche Updates in naher Zukunft)
    3. Erstellen eines Projekts aus der Kommandozeile, Erstellen und Versuchen, zu importieren
    4. Wenn Sie ein Projekt haben, das bereits funktioniert, können Sie versuchen, Dateien aus diesem Projekt zu nehmen.
    5. Lesen Sie die Protokolle, sie sind in der Regel informativer als nur die letzten 30 Zeilen, aber auf Windows müssen Sie entweder die Bildschirmpufferhöhe auf etwa 300-600 konfigurieren oder die Ausgabe an eine Datei umleiten.
    6. Sauber und wieder bauen

    Ich benutze Maven zu bauen und zu integrieren Android-Projekte mit Jenkins / Netbeans. Für die Bearbeitung von Android-Ressourcen, ich oft verwenden Eclipse wegen der ADT-Plugin und bessere Android-Ressourcen zu unterstützen.

    Eclipse (Kepler) hat ernsthafte Probleme, wenn Sie maven-basierte Android-Projekte importieren. Es erwartet die Datei project.properties im Stammordner und wird es NICHT generieren, egal was. Beispielinhalt:

     # this file is needed by eclipse (adt plugin). # Project target. target=Google Inc.:Google APIs x86:19 

    Darüber hinaus erstellen Sie eine Sym-Link namens "Gen", die auf Ziel / generierte Quellen / r, wenn mit maven, um das Android-Projekt auf der Kommandozeile zu bauen. Auf diese Weise solltest du "File-> Import …-> Vorhandenes Android-Projekt" machen können. Du bekommst eine Fehlermeldung, aber es war egal in meinem Fall.

    Zusätzliche Hinweise für den Fall, dass Sie Probleme mit m2e-Android Plugin haben:

    • Überprüfe immer, ob die Ausgabeordner für Quelldirektionen und Ressourcenverzeichnisse korrekt sind.
    • Überprüfen Sie, ob die Quell-Verzeichnisse als Quell-Verzeichnisse gesetzt sind (Sie erhalten in der Regel eine entsprechende Warnung)
    • Wenn Ressourcen aus Abhängigkeiten nicht in den letzten apk enthalten sind, überprüfen Sie die Filtereinstellungen für Ihre Ressource dirs
    • Möglicherweise müssen Sie "importieren maven Projekt aus bestehenden Quellen" vor dem Import es als Android-Projekt aus bestehenden Quellen.
    • Stellen Sie sicher, dass Abhängigkeiten in den Arbeitsbereich importiert und offen und referenziert werden (Projekt Requisiten -> Android -> Lib hinzufügen)
    • Eclipse adt unterstützt nicht aar libs, verwenden Sie apklib stattdessen

    Normalerweise bekommst du das nach einem SDK / ADT Update.

    Gehen Sie zu Ihrem SDK-Manager und stellen Sie sicher, dass es keine Updates gibt. Dann in Eclipse gehen Sie zu Hilfe> Nach Updates suchen und installieren Sie alle Updates findet es.

    Starten Sie die Sonnenfinsternis und hoffentlich sollte es alles funktionieren.

    Failing, dass Eclipse deinstallieren und Eclipse neu installieren und die Plugins nochmals beheben sollten, keine Notwendigkeit, den ganzen PC neu zu installieren.

    • Es kann passieren, wenn Sie den Speicherort von Dateien ändern, die Ihr Eclipse-Projekt verwendet.

    • In diesem Fall kannst du die Dateien direkt in den Ressourcenbereich im Arbeitsbereich kopieren, anstatt sie mit "import" zu verknüpfen

    Diese einfachen Schritte bringen mich aus diesem Ärger –

    1. In Eclipse, Hilfe-Menü -> Nach Updates suchen.
    2. Wählen Sie alle Android verwandten Plugins aus.
    3. Klicken Sie auf Weiter, Akzeptieren Sie die Seite der Vereinbarung und fahren Sie mit der Installation des Plugins fort.

    Vergewissern Sie sich, dass Ihr Java-Pfad auf das Java-SDK-Bin-Verzeichnis verweist. Vergewissern Sie sich, dass Sie die neueste JDK t sicher installiert haben.

    Sie können auch eines davon ausprobieren:

    • Schließen und öffnen Sie das Projekt in Eclipse
    • Klicken Sie rechts auf das Projekt und wählen Sie: Android Tools -> Fix Project Properties

    Ich schlug meinen Kopf gegen eine Wand für einen Tag wegen des gleichen Problems. Meine Lösung (OS X): Ich hatte eine abgestandene "java_home" Definition in meinem Profil, die auf einen toten Symlink hinweist, sowie alte Klassen in / Library / Java / Extensions. Ich habe die Definition und Symlink, zusammen mit zwei Klassen in Erweiterungen (ActiveMQ und Geronimo, FWIW) entfernt und das Problem ging weg. Nicht sicher welcher Schritt war der eigentliche "Gleichrichter", aber wenn irgendwelche dieser Bedingungen gelten, möchten Sie vielleicht sie zu überprüfen.

    Ich habe das gleiche Problem auf meinem neuen Macbook Pro, so dass ich gerade heruntergeladen JDK und installiert und Problem behoben.

    Ich habe das gleiche Problem erlebt – ich habe aktualisiert und aktualisiert Eclipse und Android Plugins und war immer noch die NPE zu sehen. Was für mich gearbeitet hat, änderte die Reihenfolge der Operationen.

    In Ordnung:

     1. update Eclipse & Android plugins 2. after the update has completed, perform the F5 Refresh in the current workspace 

    Machen Sie eine Kopie Ihres Projekts in Explorer / Finder. Löschen Sie das Projekt in ADT / Eclipse. Importiere das Projekt erneut mit Eclipse. Projekt / Sauber dann bauen Das funktioniert für mich.

    Ich habe jede Lösung ausprobiert, die ich im Internet gefunden habe und sie haben nicht gearbeitet. Dann erinnere ich mich an die Java-Version auf meinem Mac war 1.7 und ich habe die Subversion Version 1.6 installiert und das Problem ist nach dieser Installation aufgetreten. Auch ich habe Eklipse gelöscht und eine saubere Eclipse und Android sdk Installation habe ich immer noch das Problem, dann habe ich die JDK 7 deinstalliert, wie es hier gesagt wird http://docs.oracle.com/javase/7/docs/webnotes/install/mac/mac-jdk.html Und mein Problem ist gelöst.

    Ich habe mehrere Projekte in meinem Ordner. Jedes Mal, wenn ich eine neue anfange, schließe ich die anderen. Ich habe diesen Fehler, weil appcompat_v7 geschlossen wurde.

    • Klicken Sie mit der appcompat_v7 auf appcompat_v7 und wählen Sie Projekt öffnen .

    Das hat mein Problem gelöst.

    Behoben nach dem Ändern einer Einstellung in eclipse.ini . Ich verwende OS X 10.11.4 und Eclipse Mars 4.5.2 .

    1. Gehen Sie zum Ordner von Eclipse.app in Finder.
    2. Klicken Sie mit der rechten Maustaste, um ein Menü zu öffnen, und klicken Sie auf Show Package Contents .
    3. Gehen Sie zu /Contents/Eclipse .
    4. Öffnen Sie eclipse.ini in Ihrem bevorzugten Texteditor.
    5. Change -vm Pfad wie unten:

      VORHER : / Bibliothek / Java / JavaVirtualMachines / jdk1.7.0_79.jdk / Inhalt / Startseite / jre / bin

      AFTER : / Library / Java / JavaVirtualMachines / jdk1.8.0_73.jdk / Inhalt / Startseite / jre / bin

    6. Eclipse wieder öffnen

    7. Genieße: D
    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.