Google adt / gwt Unterstützung für Eclipse 4.4 (Luna)

Habe jemand die Release-Version von eclipse 4.4 mit adt (Android Entwicklung) und / oder Google Web Toolkit (GWT) zu arbeiten.

Es scheint, wie die gwt / adt-Plugins nicht mit Eclipse 4.4 arbeiten, also gibt es einen geheimen Platz, um neue Versionen herunterzuladen oder sollte ich mit 4.3 – (

  • Importieren Sie das vorhandene Android-Projekt in Eclipse: no gen source folder?
  • Dieses Android SDK benötigt Android Developer Toolkit Version 14.0.0 oder höher. ... Bitte aktualisieren Sie ADT auf die neueste Version
  • Installieren von Abhängigkeiten, die nicht in ADT r20 aufgelöst wurden
  • Wann setzt ADT BuildConfig.DEBUG auf false?
  • Eclipse ADT Unerwartete Ausnahme 'Kann Programm nicht ausführen'
  • Ich möchte den Build-Prozess anpassen, während ich noch das Android Eclipse ADT Plug-In verwende
  • Edit: Der Grund, warum ich dachte, dass adt war nicht funktioniert war, dass die Dokumentation ( http://developer.android.com/sdk/installing/installing-adt.html ) sagt, dass das Plugin heißt "ADT Plugin", was es nicht ist.

  • Drücken Sie den Inhalt, wenn Sie in den Text klicken
  • Android Studio Update schlägt fehl
  • Wie kann man ein neues Fragment aus der Navigationsschublade öffnen?
  • Android getIntent () gibt dieselbe Absicht in onResume () jedes Mal zurück. Wie kann ich das Feld in einem Bündel löschen?
  • So füge das verschiebbare Symbol mit der Navigationsschublade hinzu
  • Wie kontrolliere ich Landschaft und Porträt programmgesteuert in Android?
  • 4 Solutions collect form web for “Google adt / gwt Unterstützung für Eclipse 4.4 (Luna)”

    Google hat gerade sein offizielles SDK für Eclipse Luna veröffentlicht: https://developers.google.com/eclipse/docs/getting_started

    Für adt,

    Hilfe -> Neue Software installieren -> https://dl-ssl.google.com/android/eclipse/ -> Alles nicht auswählen

    (Es hat so gearbeitet für mich) Ich wählte alles außer Native Entwicklung Tools (ich glaube, Sie brauchen sie nicht, wenn Sie debelop in Java) und es funktioniert gut für mich.

    Gut … das gwt Plugin kann eigentlich nicht mit Luna Release arbeiten, da es eine Bündelabhängigkeit für Eclipse core.runtime [3.8.0.3.10.0) hat, hier "" bedeutet "bedeutet, dass es NICHT beinhaltet 3.10.0, die in luna verwendet wird Aber es kann man loswerden, indem man die osgi-bündel-datei modifiziert und dann wird es gut mit luna funktionieren, zumindest für mich für jetzt.

    1 download die letzte Update-Site Zip-Datei von Google Eclipse-Plugin-Website 2 entpacken Sie 3 dann müssen Sie 2 Dateien zuerst ändern

    Eine osgi META INF / Manifest-Datei in einem Jar namens * gdt * e42 enthalten (sorry, vergessen Sie den vollständigen Namen, können Sie es finden, wenn Sie versuchen, das Plugin zu installieren, wird Luna beschweren, dass einige Dep Bündel verpasst wird), die sich befindet In plugins dir, ändere gerade core.runtime version von 3.10.0) auf 3.10.0]

    Ein anderer sollte Inhalt sein. Jar (vielleicht Artefakte, Jar), ​​gleich oben

    Jetzt können Sie das Plugin installieren, wenn Sie bereits die Eclipse RCP installiert haben

    Allerdings wird die Installation fehlgeschlagen, weil das md5-Hashing geändert wird,

    Endlich kopiere das erwartete md5 aus dem Fehlermeldungsdialog, um den alten md5-Wert in artifacts.jar zu ersetzen (vielleicht content.jar)

    Jetzt das Plugin neu installieren, es sollte jetzt funktionieren


    AKTUALISIERT:

    Vielleicht solltest du die Bündel-Version von MANIFEST.MF auf com.google.gdt.eclipse.platform.e42 jar entfernen und die Version auf "0.0.0" von content.xml auf content.jar ändern

    Wenn Sie die Help----->Install New Software , können Sie diese Fehlermeldung finden, so wie ich es versuchte, das Android Plugin zu installieren.

     An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase. session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=). Error reading signed content. error in opening zip file 

    Meine Lösung war, um Help-->Eclipse Marketplace zu gehen Help-->Eclipse Marketplace und suche dann nach "Android" Wähle das Plugin aus dem Suchergebnis und installier es von dort aus.

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.