Ich kann mein Android-Projekt nicht kompilieren

Wenn ich versuche, mein Android-Projekt zu kompilieren, bekomme ich den folgenden Fehler.

Error:A problem occurred configuring project ':app'. Could not resolve all dependencies for configuration ':app:_debugCompile'. Could not find com.android.support:appcompat-v7:21.0.1. Searched in the following locations: https://jcenter.bintray.com/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.jar file:/home/baman/Android/Sdk/extras/android/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.pom file:/home/baman/Android/Sdk/extras/android/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.jar file:/home/baman/Android/Sdk/extras/google/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.pom file:/home/baman/Android/Sdk/extras/google/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.jar Required by: SriLankaTemples:app:unspecified Could not find com.android.support:recyclerview-v7:21.0.1. Searched in the following locations: https://jcenter.bintray.com/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.pom https://jcenter.bintray.com/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.jar file:/home/baman/Android/Sdk/extras/android/m2repository/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.pom file:/home/baman/Android/Sdk/extras/android/m2repository/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.jar file:/home/baman/Android/Sdk/extras/google/m2repository/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.pom file:/home/baman/Android/Sdk/extras/google/m2repository/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.jar Required by: SriLankaTemples:app:unspecified 

Hier ist meine Gradle-Datei

  • Verhindern, dass Softkeyboard auf der android-Taste zurückgelassen wird, drücken Sie
  • Hauptfaden zu viel Arbeit wegen asynchroner Firebase-Anrufe?
  • Suche nach einem "PaintCode" für Android
  • Random () in sqlite und Android sdk
  • Effektives Zwischenspeichern von Daten-Uploads in Android
  • SwipeRefreshLayout - wischen Sie sich auf, um zu aktualisieren, aber verschieben Sie die Ansicht nicht nach unten
  •   apply plugin: 'com.android.application' android { compileSdkVersion 19 buildToolsVersion "23.0.0 rc2" defaultConfig { applicationId "lk.lankahomes.baman.srilankatemples" minSdkVersion 16 targetSdkVersion 21 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile 'com.android.support:appcompat-v7:21.0.1' compile 'com.android.support:recyclerview-v7:21.0.1' } 

    Kann mir jemand helfen, dieses Dankeschön zu beheben.

  • Hat das Android-Betriebssystem Dateien wie / etc / passwd, / etc / shadow und / etc / group?
  • Statische Methoden oder Singletons Performance-Wise (Android)?
  • SearchInfo kommt immer null
  • Unterschied zwischen fokussierbarem und fokussierbareInTouchMode?
  • Android Holo Dialog hat 2 Hintergründe übereinander geschichtet
  • Gradle + Retrolambda: Schwerwiegender Fehler: Das Paket java.lang kann nicht in classpath oder bootclasspath gefunden werden
  • 3 Solutions collect form web for “Ich kann mein Android-Projekt nicht kompilieren”

    Es passiert, weil die 21.0.1 für Support-Bibliotheken nicht vorhanden ist .

    Sie können in build.gradle eins davon verwenden:

     dependencies{ //it requires compileSdkVersion 23 compile 'com.android.support:appcompat-v7:23.2.0' compile 'com.android.support:appcompat-v7:23.1.1' compile 'com.android.support:appcompat-v7:23.1.0' compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:appcompat-v7:23.0.0' //it requires compileSdkVersion 22 compile 'com.android.support:appcompat-v7:22.2.1' compile 'com.android.support:appcompat-v7:22.2.0' compile 'com.android.support:appcompat-v7:22.1.1' compile 'com.android.support:appcompat-v7:22.1.0' compile 'com.android.support:appcompat-v7:22.0.0' //it requires compileSdkVersion 21 compile 'com.android.support:appcompat-v7:21.0.3' compile 'com.android.support:appcompat-v7:21.0.2' compile 'com.android.support:appcompat-v7:21.0.0' } 

    Die gleiche Betrachtung gilt auch für die com.android.support:recyclerview-v7

    Ich sah ähnliche Problem und installierte Android SDK Build-Tools -v23.0.1 und verwies Android Setup-Guide https://facebook.github.io/react-native/docs/android-setup.html#content

    Aber konnte nicht finden "Android-Support-Repository", für die neueste Version von SDK-Manager – die Option wird in "Local Maven Repository für Support-Bibliotheken" geändert.

    Bildbeschreibung hier eingeben

    Ich denke, die buildToolsVersion "23.0.0 rc2" Linie verursacht das Problem.

    buildToolsVersion "21.0.1" es zu buildToolsVersion "21.0.1"

    Oder versuchen

     compileSdkVersion 21 buildToolsVersion "22.0.1" 

    und

     compile 'com.android.support:appcompat-v7:22.2.0' 

    Und ja was Sharj gesagt hat, ist auch richtig, vielleicht fehlen die Build-Tools

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.