Importieren Sie das vorhandene Android-Projekt in Eclipse: no gen source folder?

Ich versuche, ein AndroidProjekt in Eclipse zu importieren (von Git, aber ich glaube nicht, dass es relevant ist), und ich kann nicht laufen oder kompilieren, weil ich diese Fehler bekomme:

Android requires compiler compliance level 5.0. Please fix project properties. Serval-Video-Discovery line 1 Android ADT Problem Project 'Serval-Video-Discovery' is missing required source folder: 'gen' Serval-Video-Discovery Build path Build Path Problem 

Ich denke, das erste ist nicht wirklich ein großes Problem, auch wenn ich die Warnung nicht wirklich verstehe.

  • Wenn ich ADT lade, bekomme ich den Fehler "Das Android SDK benötigt Android Developer Toolkit Version XX.XX oder höher?"
  • Was ist der Ordner "Android Private Libraries" in Eclipse?
  • Eclipse ADT Fehler: Programm kann nicht heruntergeladen werden
  • Import Android-Projekt in ADT Eclipse von Github
  • Eclipse erstellt keine neue Aktivität und XML-Layout-Datei (Probleme nach dem Aktualisieren von Eclipse und Sdk)
  • Eclipse Android Emulator startet nicht
  • Die lustige Sache ist, dass der "gen" Ordner auf dem Dateisystem existiert; Darüber hinaus kann ich nicht versuchen, es zu schaffen, weil es bereits existiert!

    Was soll ich tun, um dieses Problem zu lösen?

    Hier ist die GitHub Repo Ich versuche zu importieren von: https://github.com/rbochet/Serval-Video-Discovery

  • Warum hört mein ProgressDialog auf irgendeinen KEY (touch) anstatt Backbutton zu entlassen?
  • Wie sichere Anmeldung bei meiner Android-App mit facebook-id?
  • Gibt es einen Nachteil bei der Verwendung von Android Support Library?
  • Gradle Error beim Erstellen eines neuen Projekts mit Android Studio
  • Android SipManager: android.net.sip.SipException: SipService.createSession () gibt null zurück
  • RecylerView blättern zur gewünschten Position ohne Animation
  • 5 Solutions collect form web for “Importieren Sie das vorhandene Android-Projekt in Eclipse: no gen source folder?”

     Package Explorer -> Right click the project -> "Android Tools" -> "Fix Project Properties" Project -> Clean 

    Behebt sich, ohne Eclipse neu zu starten

     Android requires compiler compliance level 5.0. Please fix project properties. 

    Ich hatte das gleiche Problem, aber nicht diese Antworten haben mir geholfen Ich habe meine lösung hier gefunden

    Paket-Explorer -> Rechtsklick auf das Projekt -> "Android Tools" -> "Fix Project Properties"

    Ich hatte das gleiche Problem, aber auf folgende Weise gelöst

     Package Explorer -> Right click the project -> Properties -> Java Build Path -> Source -> your project name/gen -> click on Remove -> Click on Add Folder -> check gen -> Ok -> Ok 

    Einfach mit der rechten Maustaste klicken und das Gen-Verzeichnis aus der Eclipse löschen. Wenn nicht, versuchen Sie die obigen Prozesseigenschaften.

    Wenn Gen-Ordner unter Projekt nach dem Import eines bestehenden Projekts in den Arbeitsplatz fehlt, erstellen Sie einfach einen Gen-Ordner unter Projekt und das wird den obigen Fehler beheben.

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.