Kann Android-AVD aufgrund von Target- und CPU / ABI-Einstellungen nicht erstellen?

Ich laufe Juno und fange gerade an, Android-Programmierung auf Mac zu lernen, auf dem neuesten SDK, 4.2 (API 17), und wenn ich versuche, eine AVD zu erstellen, und wie du aus dem Screenshot sehen kannst (eigentlich egal, als Neuer Benutzer darf ich keinen Screenshot posten), ich kann meinen Titel eingeben, ich kann auch mein Gerät auswählen, aber wenn ich versuche, die Dropdown-Menüs der Ziel- und CPU / ABI-Optionen zu ändern, fallen sie nicht ab überhaupt. Auch die typische Hardware-Box, in der Sie ausgewählte Hardware hinzufügen und löschen, ist nicht vorhanden, vielleicht nur wegen der neueren Eclipse-Version. Jedenfalls, warum sind mir diese Optionen nicht gegeben? Auch das endet in mir mit einer "OK" -Taste, die immer noch ausgegraut ist. Vielen Dank!

  • Android.view.InflateException: Binäre XML-Datei Zeile # 1: Fehler beim Aufblasen der Klasse <unknown>
  • "Parse Error: Es gibt ein Problem beim Parsen des Pakets" bei der Installation von Android-Anwendung
  • Wie wähle ich eine Sekunde mit TimePicker, android
  • Android NumberPicker ohne blinkenden Cursor
  • @ font-face funktioniert nicht im mobilen Webkit
  • Cordova Verbindung zum Server war nicht erfolgreich
  • Wie soll ich Belichtungs- und Weißabgleichwerte für die benutzerdefinierte Kamera einstellen
  • Ändere ActionBarSherlock Hintergrundfarbe
  • Android: state_enabled fehlt / funktioniert nicht?
  • Store Android SQLite
  • Empfangen und Verarbeiten eines Wörterbuchs <string, Liste <string >> aus Seife mit KSoap2
  • Android 9 Patch-Tool: Was ist die neue Layout-Bound-Funktion?
  • 2 Solutions collect form web for “Kann Android-AVD aufgrund von Target- und CPU / ABI-Einstellungen nicht erstellen?”

    Zuerst gehe zum SDK-Manager- Plugin deiner Eclipse / Android Studio und wähle die API-Ebene, für die du Android Virtual Device erstellen wirst. Und stellen Sie sicher, dass die API-SDK-Plattform installiert ist. Wenn SDK nicht installiert ist, dann zuerst herunterladen.

    Nach der automatischen Installation beim Herunterladen der Fertigstellung. Starten Sie Ihre Eklipse neu. Starten Sie Ihr AVD-Plugin und wählen Sie dann die API für Ihre AVD, die Sie herunterladen.

    Überprüfe dieses Bild, es zeigt, dass die SDK-Plattform für API 17 installiert ist. So können wir AVD von API erstellen 17. ABER wir können AVD von API 16 nicht erstellen, da es noch nicht installiert ist.

    Bildbeschreibung hier eingeben

    1. Verwenden Sie SDK MANAGER, um zu überprüfen, ob Ihre .img-Dateien vorhanden sind oder nicht
    2. Versuchen, auf Eclipse-Updates zu überprüfen
    3. Versuchen, eine andere API wie API 16 herunterzuladen, um zu sehen, ob es funktioniert oder nicht
    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.