MapActivity kann nicht mit einem Google API-Ziel auf einen Typ aufgelöst werden

Ich bekomme auch "den Import com.google kann nicht auf einen Typ aufgelöst werden", und ich bin mir nicht sicher, ob es verwandt ist, aber mein Projekt läuft gut auf Android 2.3.3 aber friert beim Start auf der Google API 2.3.3 und 4,0,

Ps habe ich eingeschlossen

  • NoClassDefFoundError wenn GoogleAnalyticsTracker.getInstance ()
  • Senden Sie SMS über PhoneGap auf Android
  • DeadObjectException auf Android App
  • Einen "Screenshot" eines bestimmten Layouts in Android aufnehmen
  • Abrechnung API v3 IabHelper NullPointerException
  • Die Akzeptanz wird beim Betätigen der Home-Taste zerstört.
  • <uses-library android:name="com.google.android.maps" /> 

    Bitte helfen Sie! Vielen Dank

  • Android Intent für die Aufnahme von Bildern und Videos?
  • Wie schalte ich die Lautstärke programmgesteuert auf Android?
  • Einstellen von Zeit und Datum bis zum Datum Picker und Zeit Picker in Android
  • Android View Kind hinzufügen
  • Android: Logcat zeigt nichts in Intellij IDEA
  • Wie man CA-Zertifikat programmgesteuert auf Android ohne Benutzerinteraktion installiert
  • 2 Solutions collect form web for “MapActivity kann nicht mit einem Google API-Ziel auf einen Typ aufgelöst werden”

    Sie müssen die korrekte Bibliothek zum Zeitpunkt der Kompilierung verweisen. Aber was du beschreibst, verlangt Android, diese spezifische Bibliothek zur Laufzeit zu benutzen.

    Sie müssen mit der rechten Maustaste auf Ihr Eclipse-Projekt, Eigenschaften -> Android klicken. In Project Build Target jedes Ziel mit dem Anbieter Google Inc. auswählen.

    Das Problem ist, dass Sie nicht mit dem Google Api für die spezifische Android-Plattform einfach das Betrügen der geeigneten Target Google API wird das Problem lösen.

    Bildbeschreibung hier eingeben

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.