Keytool erzeugt SHA1 Fingerabdruck statt MD5?

Ich möchte Google Maps in meiner Anwendung verwenden, ich habe dieses Tutorial gefolgt, um MD5 Fingerabdruck von meinem eventappkey.keystore zu generieren. Aber Keytool generiert SHA1 Fingerabdruck statt MD5, aufgrund der ich bin nicht in der Lage, für Google Api registrieren, wie Google akzeptiert MD5 Fingerabdruck von Keystore. Ich habe auf andere Antworten hingewiesen, die darauf […]

Android richtig aufräumen / entsorgen

Gibt es eine Möglichkeit, Objekte und andere Variablen aufzuräumen, die du erschaffst? Oder sind sie automatisch entsorgt oder habe ich dieses ganze Konzept falsch? Was ist der richtige Weg, dies zu tun? Ich versuche, den GC so weit wie möglich zu vermeiden.

Wie erkennt man meine Bildschirmorientierung im Portrait-gesperrten Bildschirm in Android?

Ich möchte die Kamera-Bildschirm-Orientierung im gesperrten Hochformat-Ausrichtungsmodus finden, gut ich benutze Kamera in meiner Fragmentklasse und ich habe bereits meine Bildschirmausrichtung als Porträt gesetzt, aber das Problem, das ich vorhabe, ist, wenn ich meine Kamera aus dem Portrait zu drehe Landschaft, die sich verändert hat, und ich muss die Capture-Taste nur dann sichtbar machen, wenn […]

Wie kann man die Unterstützung Toolbar Hintergrund transparent?

Gibt es eine Möglichkeit, die neue Android-Toolbar zu machen: android.support.v7.widget.Toolbar Haben Sie einen transparenten Hintergrund? Ich habe versucht, die colorPrimary auf einen ARGB (# 00ffffff), aber es gibt mir nur eine solide graue Bar. Und Toolbar erlaubt mir nur einen Hintergrund zu zeichnen. Ist es koscher, den Hintergrund zu einem transparenten PNG zu zeichnen, oder […]

Android Facebook Sdk Import Fehler

Ich hatte download facebook skd importiere es in meine eclipse add v4 jar datei und ändere kompilator auf 1.6 aber dennoch gibt es mir fehler in der klasse FacebookAppLinkResolver import bolts.AppLink; import bolts.AppLinkResolver; import bolts.Continuation; import bolts.Task; Oben sind nicht importieren

Cordova Build scheitert, kann nicht finden $ {appt}

Der Befehl cordova build android schlägt mit der folgenden Ausgabe fehl BUILD FAILED F:\Programs\SDK\tools\ant\build.xml:597: The following error occurred while executing this line: F:\Programs\SDK\tools\ant\build.xml:649: The following error occurred while executing this line: F:\Programs\SDK\tools\ant\build.xml:694: Execute failed: java.io.IOException: Cannot run program "F:\code\asistenciaBT\platforms\android\CordovaLib\${aapt}" (in directory "F:\code\asistenciaBT\platforms\android\CordovaLib"): CreateProcess error=2, El sistema no puede encontrar el archivo especificado Bedeutung, soweit ich […]

Android-java: check boolesche Wertprüfung für null

Ich versuche für Null Scheck wie unten if (isTrue == null) Kompilierungsfehler sagt: "Der Operator == ist undefined für den Argumenttyp (s) boolean" Bitte helfen Sie, wie Sie null überprüfen können. Vielen Dank

Konvertieren von Array von int in Bitmap auf Android

Ich habe ein MxN Array von Ints, die Farben darstellen (sagen RGBA-Format, aber das ist leicht veränderbar). Ich möchte sie in eine MxN-Bitmap oder etwas anderes (wie eine OpenGL-Textur) umwandeln, die ich auf dem Bildschirm wiedergeben kann. Gibt es einen schnellen Weg, dies zu tun? Schleifen durch das Array und Zeichnen sie auf die Leinwand […]

Phonegap run android – create Befehl fehlgeschlagen mit Exit-Code 8 – linux

Ich habe einige googleing aber finde nichts schrecklich. Jede Hilfe geschätzt. Versuchen Sie es mit einem nackten vm, um sicherzustellen, dass keine nodejs Installation oder Abhängigkeit Problem. Christian sudo apt-get install nodejs sudo apt-get install nodejs-legacy sudo npm install -g phonegap sudo npm install -g cordova sudo apt-get install ant chris@mint16 ~/project/dev $ phonegap create […]

Diamantart werden auf dieser Sprache nicht unterstützt

Nach dem Import eines Projekts in Android Studio, wenn ich das Projekt kompilieren oder ausführen möchte, wirft es einen Fehler auf: Fehler: (61, 65) java: diamond operator wird in -source nicht unterstützt 1.6 (Use -source 7 oder höher, um Diamant-Operator zu aktivieren) Weiß jemand was es ist und wie es zu lösen?

Das Android ist ein Google Android Fan-Website, Alles über Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.