Gradle Sync fehlgeschlagen konnte kein Constraint-Layout finden: 1.0.0-alpha2

Problem : Error:Could not find com.android.support.constraint:constraint-layout:1.0.0-alpha2. Required by: myapp:app:unspecified Hintergrund: Android Studio 2.2 P 1

Lieblingsinhalte werden bei webview nicht korrekt angezeigt

Ich entwickle eine Sprachwörterbuch-App. Ich rette das Lieblingswort in Präferenz. Der Favoriteninhalt in der XML-Datei sieht wie folgt aus: <?xml version='1.0' encoding='utf-8' standalone='yes' ?> <map> <string name="history"> dict_name::160170::hi,dict_name::157140::he-man,dict_name::184774::jet,dict_name::34527::black </string> <string name="waitingTime"> 0 </string> <boolean name="saveFavourite" value="true" /> <string name="defaultDictionary"> dict_name </string> <string name="favourite"> dict_name::149271::go,dict_name::25481::back,dict_name::184774::jet </string> <boolean name="saveHistory" value="true" /> </map> Ich benutze den folgenden Code, […]

App wird neu gestartet

Hoffentlich kann mir jemand helfen, herauszufinden, wenn nicht eine Lösung, zumindest eine Erklärung für ein Verhalten. Das Problem: Bei einigen Geräten führt das Drücken des Launcher-Symbols dazu, dass die aktuelle Aufgabe wieder aufgenommen wird, bei anderen wird die ursprüngliche Startabsicht abgefeuert (die Neustart der App). Warum passiert das? Das Detail: Wenn du die "Launcher Icon" […]

Warum diese Zeile xmlns: android = "http://schemas.android.com/apk/res/android" muss die erste in der Layout-XML-Datei sein?

Warum ist diese Zeile in der XML-Layoutdatei benötigt? xmlns:android="http://schemas.android.com/apk/res/android"

Was ist besser: @SuppressLint oder @TargetApi?

Ich habe Probleme in meiner App in Bezug auf StrictMode und fügte das Code-Snippet hinzu, das den StrictModeHelper grundsätzlich deaktiviert. Allerdings beschwert sich Lint jetzt über setThreadPolicy() und schlägt vor, entweder hinzuzufügen @SuppressLint 'NewApi' oder @TargetApi(Build.VERSION_CODES.GINGERBREAD) Zum onCreate() Ereignis der Ansicht. Welche Methode ist vorzuziehen .. oder sind sie im Grunde das gleiche?

So behandeln Sie Handler-Nachrichten, wenn Aktivität / Fragment angehalten wird

Leichte Abwechslung bei meinem anderen Posting Grundsätzlich habe ich eine Nachricht Handler in meinem Fragment das eine Reihe von Nachrichten erhält, die dazu führen können, dass Dialoge entlassen oder angezeigt werden. Wenn die App in den Hintergrund gelegt wird, bekomme ich eine onPause aber dann bekomme ich immer noch meine Meldungen, wie man es erwarten […]

Wie kann ich die SQLite-Datenbank auf einem Android-Gerät anzeigen?

Ich habe eine Reihe von Daten in einer SQLite-Datenbank. Ich muss die Datenbank auf einem Gerät anzeigen. Wie mache ich das? Ich habe im DDMS-Modus eingecheckt. Die Daten im Datei-Explorer sind leer.

XML Android-Berechtigungsliste Vollständig

Ich wünschte, ich könnte diese Liste finden, bevor ich es geschafft habe. Wenn du aus irgendeinem seltsamen Grund auch das brauchst, ist es hier für dich. Nur weil ich mich interessiere Nun, wie nie zuvor, geben Sie Ihren apps volle Macht. <uses-permission android:name="android.permission.ACCESS_CHECKIN_PROPERTIES" /> <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" /> <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" /> <uses-permission android:name="android.permission.ACCESS_LOCATION_EXTRA_COMMANDS" /> <uses-permission android:name="android.permission.ACCESS_MOCK_LOCATION" […]

Proguard Hölle – kann keine referenzierte Klasse finden

Also, ich versuche , einige Software freizugeben, aber Proguard gibt mir Kopfschmerzen. Wenn ich versuche, mit Proguard zu exportieren, bekomme ich viel Warnung, dh "kann nicht referenzierte Klasse finden" Beispielsweise: [2011-08-07 17:44:37 – GAME] Warning: org.simpleframework.xml.stream.StreamReader: can't find referenced class javax.xml.stream.events.XMLEvent [2011-08-07 17:44:37 – GAME] Warning: there were 52 unresolved references to classes or interfaces. […]

Android Device Chooser – Gerät nicht angezeigt

Ich benutze Eclipse + ADT, und mein physisches Gerät (siehe unten) ist nicht auf Android Device Chooser gelistet. Ich habe Eclipse und alle Android-Pakete aktualisiert. Mein Telefon läuft Android OS 1.6, was der Zielversion entspricht, die im Eclipse Project aufgeführt ist. Auch der Grund, den ich beschlossen habe, auf einem echten Gerät zu testen, ist, […]

Das Android ist ein Google Android Fan-Website, Alles über Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.