Probleme bei der Installation von Android 4.2 APIs

Ich habe ADT durch Eclipse heute auf Version 21 aktualisiert. Jetzt, wenn ich den SDK Manager eröffne, würde ich erwarten, dass es einen Ordner wie "Android 4.2 (API 17)" gibt, der die SDK Platform und APIs, Dokumentation, etc. enthalten würde. Stattdessen bekomme ich nur einen Ordner namens "API 17", und das einzige, was in ihm ist "Google APIs", die ich nicht einmal installieren kann, weil

Die Installation dieses Pakets erfordert auch die Installation: – Fehlende SDK Platform Android, API 17

  • Android doppelte Anbieter Behörde
  • Android-Statusleiste scrolling mit Koordinator-Layout, so dass Status-Icons überlappende Symbolleisten-Titel
  • Markieren Sie Text in TextView oder WebView
  • Center-Elefanten von HorizontalScrollView, wenn nicht genug, um es zu scrollen
  • Was ist Android PDK?
  • Wie man die Android-Designer-Ansicht in Intellij Idea12 verkleinern kann?
  • Was mache ich hier? Vielen Dank

  • Wie kommt es, dass Android AsyncTask keine Zukunft implementiert?
  • GetSupportActionBar () setTitle () vs toolbar.setTitle ()
  • Android: Wie kann ich wissen, ob eine Aktivität beendet ist?
  • Square Flow + Mörtel Tabletten Beispiele
  • Wie finde ich Element in View von Koordinaten x, y Android
  • Android Studio - Inspect Code - Ausgeschlossene Dateien ausschließen
  • 7 Solutions collect form web for “Probleme bei der Installation von Android 4.2 APIs”

    Ich habe mir das nach dem Stoßen herausgefunden. Ich ging in die Einstellungen für den SDK-Manager, löschte den Cache und erzählte es, HTTPS zu verwenden, dann erfrischt die Auflistung und alles erschien normal.

    Eclipse> Fenster> Android SDK Manager > Pakete > Reload

    Es hat dann die Benutzeroberfläche ordnungsgemäß aktualisiert, um mir eine aktualisierte Software zu geben.

    Warum muss ich manuell auf "Reload" klicken? Ich erwarte das automatisch, wenn ich den SDK Manager eröffne.

    Durch diesen Schritt ~

    1) Eclipse> Fenster> Android SDK Manager> Pakete> Reload

    2) dann die sdk installieren

    Ref: http://my.eoe.cn/iceskysl/archive/1027.html

    Eclipse> Fenster> Android SDK Manager> Einstellungen> Cache-Schaltfläche löschen Klicken Sie auf> Fertig.

    Ich hatte dieses Problem in Ubuntu.

    • Öffnen Sie ein Terminal und navigieren Sie zum android-sdk-linux Ordner: cd android-sdk-linux

    • Dann manuell aktualisieren die sdk: tools/android update sdk -u

    Sobald es fertig ist, starten Sie Eclipse neu.

    Als Fehler schlagen vor: API 18 hängt von SDK-Version n usw. ab. Also erstmal das SDK-Tool auf die neueste Version aktualisieren (die API 18 deaktivieren) und dann die API 18 installieren.

    Versuchen Sie, jedem Paket eine von zu genehmigen, anstatt alles zu genehmigen. Wenn ein Paket einen Fehler hat, können Sie nicht alle zur gleichen Zeit herunterladen.

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.